Android KitKat support

June 10, 2019 - 2 minutes read

Currently, Loquiz is supporting Android down to version 4.4 (KitKat). From the 01.09.2019 the support will be discontinued. After that, the oldest version Loquiz supports will be Android 5.1 (Lollipop).

You will not be able to install or update Loquiz application on the devices running Android version lower than 5.1.

Android KitKat was introduced in 2013 and is no longer officially supported by Google. We will do a major update to the Loquiz app at the end of the year. This will not allow us to support Android versions below 5.1.

What to take into account when buying devices?

If you are buying new devices, then there is no issue. All the newer Android versions are supported. If you are buying second-hand devices, please check that they have Android 5.1 or higher installed or can be updated.

What if you own old Android devices?

If you own older Android devices please check what is their OS version. If it is 5.1 or higher you are prepared.

If the Android version is lower than 5.1 then it is time to check if it can be updated officially. Just check on the device if the update is available for your OS. If update is available and you can update the device to 5.1 or higher, you are all set.

You can consider using unofficial Android updates in case the device is not officially updated by the manufacturer. Do it only if you really need to keep those devices alive and do not want to purchase newer devices. This can be complicated and might not work, so you need to really know what you are doing.

If the above does not work you will need to purchase new devices.

Similar Posts: